Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

js error, 'dp' is undefined

#113

When I try to follow the example for the firstApp, I get the following error when I try to add a property : 'dp' is undefined.

Also when I try to go to the url of the app I do not get the "hello" message http://10.98.2.22/recess/firstApp

And thirdly a little adjustment should be made to the installation instructions :

This :

On a development machine make these directories writeable by PHP:
apps/
recess/temp/
recess/sqlite/

Should read :

On a development machine make these directories writeable by PHP:
apps/
data/temp/
data/sqlite/

Reported by Philippe · August 23rd, 2012 @ 10:40 AM

State: new
Milestone: 0.20
Assigned to: Kris Jordan Kris Jordan

Activity

  1. Philippe
    Philippe

    The second problem is probably due to the fact that Apache is not using the .htaccess directives, but if I change the settings in Apache ( from AllowOverride None of AllowOverride All ), I get "Internal Server Error" when I want to go to even the recess homepage on my server.

    August 23rd, 2012 @ 11:09 AM

  2. Philippe
    Philippe

    Solved the second problem after activating mod_rewrite, so it seems this is not a suggested requirement !

    August 23rd, 2012 @ 11:13 AM

  3. Philippe
    Philippe

    Seems the last changes solved the first problem too, more than that the application looks completely different !

    When I try to create the scafolding I get the following error :

    "Invalid TableAnnotation on class "Post". Expected usage: !Table tableName == Errors == * TableAnnotation requires exactly 1 parameters. Location: Line 6 of /var/www/recess/apps/firstApp/models/Post.class.php

    2:/
    3: * !Database Default
    4: * !Table
    5: */
    6:class Post extends Model {
    7: /
    !Column PrimaryKey, String /
    8: public $title;
    9:
    10: /** !Column Text
    /
    11: public $body;"

    August 23rd, 2012 @ 11:19 AM

  4. Philippe
    Philippe

    Wow, solved it, you were not kidding when you said the page was not child proof !

    The installation instructions say nothing about entering a table name, so I skipped that part the first time, after enterting a table name all seems to be generated correctly.

    It seems all that is needed is a little update of the install instructions.

    August 23rd, 2012 @ 11:23 AM

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.